Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2026 - 10:00 CEST
Update
Release of 2026.7 is postponed until April 15th, 2026. The release will be done together with 2026.8 release.
Posted Apr 08, 2026 - 08:46 CEST
Update
Release of 2026.7 is postponed until April 8th, 2026.
Posted Mar 24, 2026 - 07:59 CET
Update
Deployment for release 2026.7 rescheduled for March 25th. at 10am. Deployment for release 2026.6 will still be performed on March 18th. at 10am as previously announced.
Posted Mar 18, 2026 - 09:56 CET
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Mar 17, 2026 - 11:25 CET
This scheduled maintenance affected: Wavely APIs and Wavely Portal.